of course, less memory usage of router. ;)
Let's go!
Example of network:
Configurations ResuMe:
R1# sh run
Building configuration...
Current configuration : 1041 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
ip name-server 0.0.0.0
!
!
interface Serial0/0/0
bandwidth 64
ip address 10.0.0.2 255.255.255.252
ip summary-address eigrp 100 172.1.4.0 255.255.252.0 5
!
interface Serial0/1/0
ip address 172.1.5.1 255.255.255.0
clock rate 64000
!
interface Serial0/1/1
ip address 172.1.6.1 255.255.255.0
clock rate 64000
!
interface Serial0/2/0
ip address 172.1.7.1 255.255.255.0
clock rate 64000
!
interface Serial0/2/1
ip address 172.1.4.1 255.255.255.128
clock rate 64000
!
interface Serial0/2/2
ip address 172.1.4.129 255.255.255.128
clock rate 64000
!
!
!
router eigrp 100
redistribute static
network 10.0.0.0
network 172.1.0.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.1
!
end
The more importante coMMand here is:
ip summary-address eigrp 100 172.1.4.0 255.255.252.0
This problem is more of a design issue. The main issue is that
Router R1 summary route is too broad and includes nonexistent
subnets. Also, Router R1 is sending a more general summary
route (default route) to Router ISP. The solution is to have Router
R1 send out only the summary route that covers the 172.1.4.0
through 172.1.7.0 networks. In other words, instead of sending
the 172.1.0.0/16 summary route, Router R1 can send the
172.1.4.0 255.255.252.0 summary route to Router ISP.
See router table of ISP and after this applicable:
Before:
ISP# sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0/0
172.1.0.0/16 is variably subnetted, 5 subnets, 2 masks
D 172.1.4.0/25 [90/20514560] via 10.0.0.2, 00:00:08, Serial0/0/0
D 172.1.4.128/25 [90/20514560] via 10.0.0.2, 00:00:08, Serial0/0/0
D 172.1.5.0/24 [90/21024000] via 10.0.0.2, 00:00:08, Serial0/0/0
D 172.1.6.0/24 [90/21024000] via 10.0.0.2, 00:00:08, Serial0/0/0
D 172.1.7.0/24 [90/21024000] via 10.0.0.2, 00:00:08, Serial0/0/0
After:
ISP# sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Serial0/0/0
172.1.0.0/22 is subnetted, 1 subnets
D 172.1.4.0 [90/20514560] via 10.0.0.2, 00:00:07, Serial0/0/0
cool no?
RA configuration:
interface Serial0/0
interface Serial0/0
no shut
bandwidth 64
ip address 172.1.4.2 255.255.255.128
router eigrp 100
network 172.1.0.0
no auto-summary
bandwidth 64
ip address 172.1.4.2 255.255.255.128
router eigrp 100
network 172.1.0.0
no auto-summary
RB configuration:
interface Serial0/0
interface Serial0/0
no shut
bandwidth 64
ip address 172.1.4.130 255.255.255.128
router eigrp 100
network 172.1.0.0
no auto-summary
bandwidth 64
ip address 172.1.4.130 255.255.255.128
router eigrp 100
network 172.1.0.0
no auto-summary
RC configuration:
interface Serial0/0
no shutinterface Serial0/0
bandwidth 64
ip address 172.1.5.2 255.255.255.0
router eigrp 100
network 172.1.0.0
no auto-summary
RD configuration:
interface Serial0/0
no shutinterface Serial0/0
bandwidth 64
ip address 172.1.6.2 255.255.255.0
router eigrp 100
network 172.1.0.0
no auto-summary
RE configuration:
interface Serial0/0
no shutinterface Serial0/0
bandwidth 64
ip address 172.1.7.2 255.255.255.0
router eigrp 100
network 172.1.0.0
no auto-summary
How I find the 172.1.4.0 255.255.252.0 ???
Simple, See:
172.1.4.0 = I0I0II00.0000000I.00000I00.00000000
172.1.5.0 = I0I0II00.0000000I.00000I0I.00000000
172.1.6.0 = I0I0II00.0000000I.00000II0.00000000
172.1.7.0 = I0I0II00.0000000I.00000III.00000000
How many bits in common?
172.1.4.0 = I0I0II00.0000000I.00000I00.00000000
172.1.5.0 = I0I0II00.0000000I.00000I0I.00000000
172.1.6.0 = I0I0II00.0000000I.00000II0.00000000
172.1.7.0 = I0I0II00.0000000I.00000III.00000000
So, I0I0II00.0000000I.00000I is 22 that its equal a 255.255.252.0!
biOos
No comments:
Post a Comment