Think before you type.
With great power comes great responsibility.
IF you don´t take control of your data, someone else Will.
The only Way to Stop a Hacker is to think like One
To gain knowledge there is no shortcut
17 May 2014
Quick Notes - BGP Neighbors
* This network provides full reachability and uses one route-map to change the preference of 200 network.
[R1]
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
ip address 200.0.0.1 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
ip address 10.0.0.1 255.255.255.0
serial restart-delay 0
!
interface Serial0/2
ip address 189.0.0.1 255.255.255.0
serial restart-delay 0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
network 10.0.0.0 mask 255.255.255.0
network 189.0.0.0 mask 255.255.255.0
network 200.0.0.0
neighbor 2.2.2.2 remote-as 2
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
neighbor 3.3.3.3 remote-as 3
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source Loopback0
neighbor 10.0.0.2 remote-as 1
neighbor 10.0.0.2 next-hop-self
no auto-summary
!
ip route 2.2.2.2 255.255.255.255 200.0.0.2
ip route 3.3.3.3 255.255.255.255 189.0.0.3
[R2]
interface Serial0/1
ip address 10.0.0.2 255.255.255.0
serial restart-delay 0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.0.0.1 remote-as 1
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 10.0.0.1
[R3]
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
ip address 200.0.0.2 255.255.255.0
serial restart-delay 0
!
interface Serial0/3
ip address 100.0.0.2 255.255.255.0
serial restart-delay 0
!
router bgp 2
no synchronization
bgp log-neighbor-changes
network 100.0.0.0 mask 255.255.255.0
network 200.0.0.0
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback0
neighbor 3.3.3.3 remote-as 3
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 route-map metricToR4 out
no auto-summary
!
ip route 1.1.1.1 255.255.255.255 200.0.0.1
ip route 3.3.3.3 255.255.255.255 100.0.0.3
!
ip prefix-list prefix200 seq 5 permit 200.0.0.0/24
!
route-map metricToR4 permit 10
match ip address prefix-list prefix200
set metric 100
!
route-map metricToR4 permit 20
[R4]
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 48.0.1.1 255.255.255.0
!
interface Serial0/2
ip address 189.0.0.3 255.255.255.0
serial restart-delay 0
!
interface Serial0/3
ip address 100.0.0.3 255.255.255.0
serial restart-delay 0
!
router bgp 3
no synchronization
bgp log-neighbor-changes
network 48.0.1.0 mask 255.255.255.0
network 100.0.0.0 mask 255.255.255.0
network 189.0.0.0 mask 255.255.255.0
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback0
neighbor 2.2.2.2 remote-as 2
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
ip route 1.1.1.1 255.255.255.255 189.0.0.1
ip route 2.2.2.2 255.255.255.255 100.0.0.2
[*] BGP Resources
biOos
Subscribe to:
Post Comments (Atom)
No comments:
Post a Comment